Software - Real Time Monitor Funkció ismertetése

Software - Real Time Monitor Funkció ismertetése

‎Ez a dokumentum a Valós idejű monitor funkciót ismerteti‎


‎1. A program elindításának lehetőségei

‎A valós idejű monitor funkció elindításának két módja van.‎

‎1.1. Valós idejű monitor funkció a GX Works Tool menüből‎

‎A PLC  változók monitorozásának megkezdéséhez nyissa meg a Tool->Real Time Monitor funkciót a menüsorról:‎


‎1.2 GX Log viewer

‎Válassza ki a csatlakozási célt (CPU, szimulátor vagy naplózási modul), majd kattintson az Show current/Device Label status megjelenítése parancsra:‎


‎Adjuk meg a Szimulátor‎számát/CPU‎





‎1.3. A kapcsolat  módjának megváltoztatása‎

‎A csatlakozási lehetőségek elérhetőek:  Online->Realtime Monitor‎



‎2. Felügyeleti/Monitoring adatok‎

‎2.1 Valós idejű monitor beállítása‎

‎A figyelésre szánt Deviceok/eszközök jobb egér klikkel menjen bele a Valós idejű monitor beállításaiba. Amikor a Valós idejű figyelőtaGX Works3- ból indítja , a beállítási ablak automatikusan elindul. ‎


‎A figyelendő adatokat válaszhatjuk a CPU-memóriából vagy buffer memóriából. Lehetőség van konfigurációs fájlok írására és olvasására. ‎



‎RCPU esetén címkéket is olvashat. Kattintson a GXWorks3 Projekt olvasása elemre, válassza a projektfájlt (Olvassa be a GX Works3 Projektet), és válassza a Címke megadása lehetőséget:‎


‎2.2. A monitorozás feltételeinek beállítása

‎A Monitor beállításaiban beállíthatja az időzítés típusát (alapértelmezettként minden scan ciklus) és trigger típusát:‎





‎3. Grafikon‎



‎3.1 Navigáció‎

‎Van néhány hasznos navigációs kapcsoló:‎

‎1. Az ellenőrzés indítása/ leállítása‎
‎2. Grafikon igazítása és egymásra helyezése‎
‎3. Több kurzor használata - hasznos az időméréshez‎
‎4. Grafikon automatikus skálázása‎
‎5. Kurzor értéke‎

‎3.2 Grafikonméret-beállítások‎

‎Méretezés


Grafikon mozgatása


‎Időskálázás beállítása‎



















‎A felső/alsó határok megadása‎

‎-Manuálisan a határok értékére kattintva:‎















‎- Grafikonművelet -> Felső/alsó határ/Y tengelyméret módosítása több változó esetén: ‎

















‎3.3 Grafikonadatok mentése és olvasása‎

‎A Fájl->Save As  segítségével graikonjainkat  (Unicode szövegfájlként vagy képfájlként) menthetjük. A grafikon beolvasásához használja a Megnyitás lehetőséget:‎



‎3.4 Mentse el és olvassa be a grafikus megjelenítési beállításokat‎

‎A grafikus beállítások (méretezés, határok) nem kerülnek automatikusan mentésre a naplófájllal. A grafikus beállítások mentéséhez használja a Graph View -> Register Graphical Display Settings parancsot...‎


‎A grafikus megjelenítési beállítások olvasásához használja az Operate Graphical Display settings beállításokat. 

‎3.5 Grafikus megjelenítési beállítások importálása/exportálása‎

‎Nyissa meg a File->Import és Exportálás. Válassza ki a grafikus megjelenítési beállítások importálását/exportálását, és adja meg a fájlt. 


‎3.6 Idő- és különbség mérésre példa‎

‎Állítsa be a Több kurzor használatát, és mozgassa a kék és a piros kurzort a kívánt helyre:‎



















 
















‎Bontsa ki az időskálát, és állítsa be pontosan a kurzorokat:‎
‎jobb egérgombbal > Piros/kék kurzor mozgatása Itt:‎





‎Olvassa le a különbség értékét (Difference (Blue->Red) vagy az időt (Span (Blue->Red).‎